The Frontier awaits: Legends of Equestria's Summer Update is Live!

Started by Ellowee, 2019 Sep 22, 16:46:52

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Go Down

Ellowee

Hey again, everypony! It's been a little while since we last spoke, huh? Well, at least I'm bringing some big news to you: our long-awaited summer update (version 2019.02.01) is now available from our downloads page!

For the first time ever, the Equestrian railroads now reach all the way to the distant outposts of Applewood and Dodge Junction, deep in the Equestrian Frontier. This brings whole new areas to explore, and so much additional content that you can barely swing a rattler without hitting something new! Not that I'd recommend swinging any kind of snake, obviously.



The Frontier is a large, barren landscape, but that doesn't mean that there isn't plenty to explore in this new environment. Be careful! Getting lost is easy, and you never know where you might find cliffs, caverns, or dangerous creatures. The west is still very wild!



We've also had our landscaping team hard at work, and they've brought you a new park on the outskirts of Ponydale; reports are also coming in of hidden caverns deep beneath the Crystal Kingdom.

On top of new locations, we've also added and updated a bunch of items, such as the new textures on Harmonious and Elementium armor! Astound your friends and foes alike with your sparkling new gear.



Climbing and jumping boots are now available as a reward for ponies who can brave the intimidating critters of the Bramble Woods. As the fashionable footwear's names suggest, they'll help enhance your abilities to jump higher, or climb the steepest of hills.



Let's also not forget that this seasonal update brings with it our yearly event, the Festival of Lights! Now's your chance to celebrate the glow of friendship that brings all the creatures of Equestria together, and help to craft the unique lantern or torch for the event. To help commemorate the occasion, the finest alchemists of the Crystal Kingdom have worked diligently to create exciting new fireworks for everypony to enjoy!

On top of all that, we've reached our second year of being fully accessible 24/7 (barring the occasional server oopsie, of course)! So in celebration of our anniversary, you can expect a scrumptious new hat celebrating two years of pastel ponies!

As always, this isn't everything we've added or changed over the past few months; if you want to check out the numerous quest and bug fixes, you can find all the details in the changelog.

We've still got plenty more wonderful things planned ahead, and we're already working on the next batch of additions to the world this team loves so much. In the meantime, have fun exploring the new reaches of Equestria!

Sammyatmoms

excuse me sorry to interrupt you but i love this game, but one thing missing, i really want to be an alicorn, i mean a real alicorn, but if you have a chance to make an alicorn for anypony, everypony well be appreciated for your hard work, well be so glad to do that, i know it's a hard thing to do but if you do that for us well be gladly appreciated for your hard work, and plz do that for everypony don't let anypony down, thinks, P.S. love the new update

StarFrith

Oh sweet! Would you look at that armor! Plus new places to explore? Fabulous! Thanks for all the hard work, LoE team!

QuinTAI


Night Azure

does anyone know how long the update will take so I can play again?

Even Tide

For anyone having trouble getting back in-game, try re-installing from the downloads page. The version on there may look outdated, but a number of us have confirmed that this does work.

Reese

I'm trying to run the Mac version of v2019.02.01, but it's not working.  Clicking on the application launches it, but the LoE window never appears; the application doesn't appear to do anything.  Launching the executable from the command line works just as well, but only produces this in terms of output:
Code Select
$ ./LoE
CrashReporter: initialized
Mono path[0] = '/Users/REDACTED/Desktop/LoE.app/Contents/Resources/Data/Managed'
Mono config path = '/Users/REDACTED/Desktop/LoE.app/Contents/Mono/etc'
Any ideas?  If nothing else, how likely is the game (and maybe the launcher too) to run in Wine?
Thanks!

Cyan Spark

Quote from: Reese on 2019 Sep 27, 03:42:21I'm trying to run the Mac version of v2019.02.01, but it's not working.  Clicking on the application launches it, but the LoE window never appears; the application doesn't appear to do anything.
What version of macOS are you running? LoE now uses the Metal API. Did you try lifting the WebKit quarantine?

Code Select
xattr -dr com.apple.quarantine /Applications/LoE.app/

Reese

Quote from: Cyan Spark on 2019 Sep 27, 22:54:00What version of macOS are you running? LoE now uses the Metal API. Did you try lifting the WebKit quarantine?

Code Select
xattr -dr com.apple.quarantine /Applications/LoE.app/
Ah, 10.11.6, sorry; should have thought to say that before.
From a bit of quick research, looks like the Metal API shouldn't be a problem...
I'll try that code (after moving the application to Applications).

Seemed to execute alright; now trying to launch the application...

...Hm.  Doesn't seem to have changed behavior from clicking on the application, unfortunately.

...Nor from directly running the executable, though the output is now:
Code Select
$ ./LoE
CrashReporter: initialized
Mono path[0] = '/Applications/LoE.app/Contents/Resources/Data/Managed'
Mono config path = '/Applications/LoE.app/Contents/Mono/etc'
Then, as before, it appears to just sit there doing nothing (not frozen, to be clear; what few controls it gives me are responsive) until I quit.

The latest version before this I ran was build 2018.10.01, which still launches fine to the login screen, if that helps.

(And thanks for trying to help; hopefully we can get this sorted out.  :))

Cyan Spark

Hm, I'm not sure what might be causing the window's failure to appear. There might be a bad window size setting in your user preferences. Try deleting the Legends of Equestria folder at
Code Select
~/Library/Application support/LoE and see if that resolves the issue.

Other than that, I'd advise updating to Mojave, as that's the version I use to run LoE.

Reese

Hm.  That didn't work, nor did a new preferences window (which for me is unity.LoE.Legends of Equestria, not just LoE; might that mean anything?) generate.

Oh well.  I've no plans to update right now, so I might just try the Windows version in Wine.  Don't have time for that just at this moment, though.

Thanks for trying to help, again, even if the odds of success look rather lower now.

...Hm.  Another thing I've noticed: when starting the old version, at least by clicking on the application, my cursor changes to the quill pretty much immediately on finishing the double click; with the new version, it doesn't change at all.  Does that provide any useful information?

Go Up